Open Source e-Learning
  • Login

Breadcrumb Navigation

Icon Wiki

Feature Wiki

Information about planned and released features

Tabs

Required and Supported Software ILIAS 6

1 Required Software Versions

The following software versions are required/supported for ILIAS Release 6.
  • PHP:
  • PHPUnit:
  • DBMS:
    • MariaDB: 10.0 - 10.2
    • MySQL:  5.6 - 5.7
    • Postgres 9.x
  • HTTP Server
    • Apache: >= 2.4.x
    • nginx: >= 1.12.x
  • Java: 7 - 8
  • NodeJS: 8.9.4 (LTS) - 10.15.3 (LTS)
  • PDF Generation:
    • PhantomJS: The development is suspended, see: https//phantomjs.org
    • The Technical Board suggests a core integration of a wkhtmltopdf or 'Headless Chrome' renderer. We contacted the responsible maintainer.
  • unzip: 6.0+
  • zip: 3.0+
  • Imagemagick: 6.8.9-9+
  • Browsers:
    • Desktop:
      • ILIAS supports current versions of Firefox and Chrome. The browser support for particular views or features can be limited due to browser CSS/JavaScript limitations.
      • IE 11: Limited support. Basic functionality will be available, visuals and user experience may be substandard.
    • Mobile:
      • We're discussing how to design specific views for mobile devices, particularly elements that may be missing due to UI considerations.

2 Contact

  • Author of the Request: Jansen, Michael [mjansen] on behalf of the ILIAS e.V. and the Technical Board ( tb [at] lists [dot] ilias [dot] de)

3 Funding

Currently no indication that funding will be needed.
  • If you are a maintainer and see a need for funding, please adress the Technical Board.
  • If you are a user/decision maker and interested in a particular software or software version being supported, please contact the Technical Board as well.

4 Discussion

We highly appreciate the PHP 7.3 since it will become standard PHP version in Debian 10. Also support for Maria DB 10.2 and nginx are appreciated. Rocho, Jan [jrocho]
Erkens, Jochen [j.erkens] Since the security support for 7.1 ends in December 2019, it makes no sense to need this version for ILIAS 6.0. http://php.net/supported-versions.php
Becker, Maximilian [mbecker] 2019-03-14 I would find it beneficial to also list supported platforms here and among those Windows as well as a remark that Linux platforms are only officially supported if they rely on proper, standard packet sources.
Kaulard, Jonathan [jkaulard] 2019-03-15 In April 2020 a new Ubuntu LTS Version (20.04) will be released. According to experience the latest PHP-Version (7.4/8.0) will become standard PHP version. Due to Ubuntu is also very popular and often used for webserver purposes this PHP Version should be supported by ILIAS too. Otherwise Ubuntu administrators will have to downgrade to an older PHP version e.g by using external repositories, which is not the ideal solution.
Schenk, Ralf [rschenk] 2019-03-17 Since MariaDB 10.3 is already declared stable, support of MariaDB should include 10.3.x. There are only minor compability changes documented. See: https://mariadb.com/kb/en/library/changes-improvements-in-mariadb-103/
JourFixe, ILIAS [jourfixe], 25 MAR 2019 : We keep the discussion open until next Jour Fixe. This will allow us to collect some feedback from DevConf participants this week.
Seeland, Per Pascal [PerPascalSeeland]:  The java requirement should be changed from 7-8 to 8 and 11. 8 is the current LTS version and 11 will become the new one this year.
JourFixe, ILIAS [jourfixe], 08 APR 2019: We would like to extend the current list of required software for JAVA to 8-11 and for MariaDB to 10.3 but ask the related maintainer (Stefan Meyer and Fabian Schmid) to check this before we make a final decision at the next Jour Fixe at April 24, 2019.
JourFixe, ILIAS [jourfixe], 24 APR 2019 : Final decision postponed to May 07, 2019. Latest checks for JAVA 11 and MariaDB 10.3 need more time.
Schmid, Fabian [fschmid], 24 APR 2019: Installation of trunk works with MariaDB 10.3 (MyISAM and InnoDB as well), no further tests were made.
JourFixe, ILIAS [jourfixe], 07 MAY 2019 : Due to the missing feedback of Stefan we do not extend the software requirements for ILIAS 6.0 to JAVA 11 but keep them as they are for JAVA 7 and 8. Rest is accepted.

Last edited: 31. Jul 2019, 00:01, Kunkel, Matthias [mkunkel]


Search (Block)

Wiki Functions (Block)

Info

Recent Changes